Skip to main content

Effective 10 September 2024, API Documentation can be found on our Equinix Product Documentation site.
The content on this page will not be updated after 1 Oct 2024 and will be inaccessible after 31st Dec 2024.


Device Backup & Restore

Check Feasibility of Restore

 GET /ne/v1/devices/{uuid}/restoreAnalysis
MethodGET
URL or End Point/ne/v1/devices/{uuid}/restoreAnalysis
HeadersAuthorization, Content-Type
Path Parametersuuid
Query ParametersbackupUuid
BodyNot applicable

Checks the feasibility of restoring the backup of a virtual device.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

A sample curl request.

curl -X
GET "https://api.equinix.com/v1/devices/4cfb5675-5c3f-4275-adba-0c9e3c26c96b/restoreAnalysis?backupUuid=d186dc1a-29e7-4829-bb5e-50fa57aca923"
-H "content-type: application/json"
-H "authorization: Bearer qwErtY8zyW1abcdefGHI"

The description of the path parameters is as follows:

Path ParameterMandatoryTypeExampleApplicable ValuesDescription
uuidYesstringd186dc1a-29e7-4829-bb5e-50fa57aca923The unique Id of a device.

The description of the query parameter is as follows:

Query ParameterMandatoryTypeExampleApplicable ValuesDescription
backupUuidYesstring7ef81cbe-01ed-4c27-8b2f-69d3a3fd4d6aThe unique Id of a backup.

Sample response:

{
"deviceBackup": {
"uuid": "326cf3fb-4b41-48a7-a4f4-24355c3e964f",
"name": "l3_l2(aws-2)",
"status": "COMPLETED",
"deleteAllowed": false
},
"services": {
"L3_CONNECTION": [
{
"serviceDetails": {
"uuid": "369427e6-ee59-4c73-ae47-fda9bb7ed886",
"serviceId": "ac8a8497-1b6e-42d1-9075-acf23a62ed50",
"serviceName": "L3_CONNECTION",
"data": {
"id": "ac8a8497-1b6e-42d1-9075-acf23a62ed50",
"name": "l3",
"vlan": 5642,
"overlayIpCidr": "64.191.223.87/31"
}
},
"operationNeededToPerform": "UNSUPPORTED",
"restorable": false
},
{
"serviceDetails": {
"serviceId": "a0d98ad0-6c70-4a87-b21f-ea4741314509",
"serviceName": "L3_CONNECTION",
"data": {
"id": "a0d98ad0-6c70-4a87-b21f-ea4741314509",
"name": "l3-backup",
"vlan": 6825,
"overlayIpCidr": null
}
},
"operationNeededToPerform": "DELETE",
"restorable": false
}
],
"L2_CONNECTION": [
{
"serviceDetails": {
"uuid": "421e4f28-f40e-4ddc-a6ec-ff588f293646",
"serviceId": "a2b21256-370f-4119-95cf-21452b0ddbc6",
"serviceName": "L2_CONNECTION",
"data": {
"id": "a2b21256-370f-4119-95cf-21452b0ddbc6",
"name": "l2-aws",
"vlan": 5644,
"overlayIpCidr": "10.0.1.1/30"
}
},
"operationNeededToPerform": "UNSUPPORTED",
"restorable": false
},
{
"serviceDetails": {
"uuid": "bdd2cc7a-7e30-4f5c-82f7-cba6eb54781a",
"serviceId": "53926de5-35eb-49fb-bf62-8f513c7e9fe8",
"serviceName": "L2_CONNECTION",
"data": {
"id": "53926de5-35eb-49fb-bf62-8f513c7e9fe8",
"name": "l2-aws-2",
"vlan": 5647,
"overlayIpCidr": null
}
},
"operationNeededToPerform": "UNSUPPORTED",
"restorable": false
}
],
"BYOC": [
{
"serviceDetails": {
"serviceId": "506a1657-318f-496f-8d7d-a1fa919c67a1",
"serviceName": "BYOC",
"data": {
"id": "506a1657-318f-496f-8d7d-a1fa919c67a1",
"name": "",
"vlan": 6823,
"overlayIpCidr": null
}
},
"operationNeededToPerform": "DELETE",
"restorable": false
}
],
"VPN": [
{
"serviceDetails": {
"serviceId": "7e4c3dc3-b0db-4f9b-9f03-1cb3f6e26735",
"serviceName": "VPN",
"data": {
"configName": "SROY-VPN",
"peerIp": "100.210.1.31",
"peerSharedKey": "5bb2424e888bd",
"remoteAsn": 10013,
"remoteIpAddress": "100.210.1.220",
"password": "123456",
"localAsn": 10012,
"tunnelIp": "192.168.7.2/30",
"siteName": "Chicago",
"uuid": "7e4c3dc3-b0db-4f9b-9f03-1cb3f6e26735",
"status": "PROVISIONING_FAILED",
"bgpState": "Idle",
"tunnelStatus": "DOWN",
"useNetworkServiceConnection": false,
"createdDate": "2021-04-21T18:09:39.232Z",
"createdByFullName": "nfvsit02 nfvsit02",
"createdByEmail": "nfvsit02@equinix.com",
"createdBy": "nfvsit02",
"lastUpdatedDate": "2021-04-21T18:12:11.876Z",
"virtualDeviceUUID": "fc135217-c3a3-4823-97bc-8447cc723f38",
"lastUpdatedByFullName": "nfvsit02 nfvsit02",
"lastUpdatedByEmail": "nfvsit02@equinix.com",
"lastUpdatedBy": "nfvsit02"
}
},
"operationNeededToPerform": "DELETE",
"restorable": false
}
],
"BGP": [
{
"serviceDetails": {
"uuid": "744f164f-12ca-46b9-bc6e-d0dca3d46f54",
"serviceId": "95d17fa0-f00a-4ece-be13-21001c6a125a",
"serviceName": "BGP",
"data": {
"uuid": "95d17fa0-f00a-4ece-be13-21001c6a125a",
"state": "Established",
"localAsn": 12345,
"createdBy": "nfvsit02",
"remoteAsn": 25658,
"createdDate": "2021-04-19T18:51:41.193Z",
"connectionName": "l3",
"connectionUuid": "ac8a8497-1b6e-42d1-9075-acf23a62ed50",
"createdByEmail": "nfvsit02@equinix.com",
"localIpAddress": "64.191.223.87/31",
"remoteIpAddress": "64.191.223.86",
"createdByFullName": "nfvsit02 nfvsit02",
"virtualDeviceUuid": "cfa358bb-fcb7-4d0e-963a-4d7632d7c111",
"provisioningStatus": "PROVISIONED"
}
},
"operationNeededToPerform": "UNSUPPORTED",
"restorable": false
},
{
"serviceDetails": {
"uuid": "187b5951-0413-48e1-beeb-f2c93e859a5a",
"serviceId": "36307862-5a29-49c4-a8bf-ce996508a309",
"serviceName": "BGP",
"data": {
"uuid": "36307862-5a29-49c4-a8bf-ce996508a309",
"state": "Idle",
"localAsn": 12345,
"createdBy": "nfvsit02",
"remoteAsn": 21345,
"createdDate": "2021-04-20T18:56:02.689Z",
"connectionName": "l2-aws",
"connectionUuid": "a2b21256-370f-4119-95cf-21452b0ddbc6",
"createdByEmail": "nfvsit02@equinix.com",
"localIpAddress": "10.0.1.1/30",
"remoteIpAddress": "10.0.1.2",
"createdByFullName": "nfvsit02 nfvsit02",
"virtualDeviceUuid": "cfa358bb-fcb7-4d0e-963a-4d7632d7c111",
"provisioningStatus": "PROVISIONED"
}
},
"operationNeededToPerform": "UNSUPPORTED",
"restorable": false
}
],
"ACL": [
{
"serviceDetails": {
"serviceId": "c2f99f55-2075-4496-bb6a-e7524678b6f4",
"serviceName": "ACL",
"data": {
"aclTemplate": {
"name": "FTtesttemplate",
"uuid": "c2f99f55-2075-4496-bb6a-e7524678b6f4",
"description": "",
"inboundRules": [
{
"srcType": "SUBNET",
"seqNo": 1,
"subnets": [
"15.0.0.0/8"
],
"protocol": "IP",
"srcPort": "any",
"dstPort": "any"
}
],
"metroName": "Silicon Valley",
"metroCode": "SV",
"createdBy": "nfvsit02",
"createdDate": "2021-04-07T23:31:00.248Z"
},
"status": "PROVISIONED"
}
},
"operationNeededToPerform": "UNSUPPORTED",
"restorable": false
}
],
"LICENSE": [
{
"serviceDetails": {
"uuid": "a539d322-dc00-4612-a999-8ecea33e0d89",
"serviceId": "cfa358bb-fcb7-4d0e-963a-4d7632d7c111",
"serviceName": "LICENSE",
"data": {
"virtualDeviceUuid": "cfa358bb-fcb7-4d0e-963a-4d7632d7c111"
}
},
"operationNeededToPerform": "NONE",
"restorable": true
}
],
"DEVICE_LINKING": []
},
"restoreAllowedAfterDeleteOrEdit": false,
"restoreAllowed": false
}

The description of the response payload is as follows:

FieldTypeExample ValuesDescription
deviceBackupobjectAn object that has the device backup details.
uuidstring4cfb5675-5c3f-4275-adba-0c9e3c26c96bThe unique ID of the device backup.
namestringL3_L2_backupThe name of the backup.
statusstringCOMPLETEDThe status of the backup.
deleteAllowedbooleanfalseWhether you can delete this backup.
servicesobjectAn object that has the detailed analysis of the services available on the backup or added to the device since the backup. Possible services include L3_CONNECTION, L2_CONNECTION, BYOC, VPN, BGP, ACL, LICENSE, DEVICE_LINKING.
serviceDetailsobjectAn object that has the details of a service.
serviceIdstringac8a8497-1b6e-42d1-9075-acf23a62ed50The service ID.
serviceNamestringL3_CONNECTIONThe type of service.
dataobjectData associated with the service. To understand the fields associated with services, check out the following APIs:  Get L2 Connection {uuid}; Get VPN Configuration {uuid}, Get BGP Peering {uuid}, Get ACL Template {uuid}, Get Device Link {uuid}
operationNeededToPerformstringUNSUPPORTEDUNSUPPORTED: we do not support restoring this backup. 
NONE: You do not need to change anything to restore this backup. 
DELETE: You need to delete this service to restore the backup.
restoreAllowedAfterDeleteOrEditbooleanfalseTrue: The backup is restorable once you perform the recommended operations. False: The backup is not restorable.
 

If you get “Access Denied” error, contact your local Equinix Service Desk.

Create Device Backup

 POST /ne/v1/deviceBackups
MethodPOST
URL or End Point/ne/v1/deviceBackups
HeadersAuthorization, Content-Type
Query ParametersNot applicable
BodydeviceUuid, name

Creates the backup of a device. We create Config backups of Equinix-Configured devices and Image Snapshots of Self-Configured devices. However, you can only download Config backups.  

If you are updating the primary device of a device pair, the secondary will still be usable. You cannot have more than 30 backups of a device.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

Sample curl request:

curl -X
POST "https://api.equinix.com/ne/v1/deviceBackups"
-H "content-type: application/json"
-H "authorization: Bearer qwErtY8zyW1abcdefGHI"
-d "
{
"deviceUuid": "63b710e3-e7b8-4614-a3d4-ffe768021a62",
"name": "my SROY Backup"
}
"

Sample response:

202 Accepted

{
"id": "7c26b2c4-d666-4942-a5d4-50152341ecc2"
}

The description of the response payload: 202 Accepted

FieldTypeExample ValuesDescription
idstring7c26b2c4-d666-4942-a5d4-50152341ecc2The ID of the new backup that is being created.
 

If you get “Access Denied” error, contact your local Equinix Service Desk.

Delete Backup of Device

 DELETE /ne/v1/deviceBackups/{uuid}
MethodDELETE
URL or End Point/ne/v1/deviceBackups/{uuid}
HeadersAuthorization, Content-Type
Query ParameterNA
Path ParameterUnique Id of a backup.
BodyNA

Deletes a backup by its unique ID. Only backups in "Completed" or "Failed" states can be deleted.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

The following screenshot shows a sample curl request.

curl -X
DELETE "https://api.equinix.com/ne/v1/deviceBackups/5f888d91-d2c5-45bb-9b51-fed99f57f0ac"
-H "content-type: application/json"
-H "authorization: Bearer qwErtY8zyW1abcdefGHI"
Path Parameter NameMandatoryTypeExampleApplicable ValuesDescription
uuidYesstring5f888d91-d2c5-45bb-9b51-fed99f57f0acUnique Id of a backup. Only backups in "Failed" or "Completed" states can be deleted.

Sample response:

204: No Content.

The description of the response is as follows:

HTTP StatusDescription
204: No ContentDeletion request fulfilled.
 

If you get “Access Denied” error, contact your local Equinix Service Desk.

Download a Backup

 GET /ne/v1/deviceBackups/{uuid}/download
MethodGET
URL or End Point/ne/v1/deviceBackups/{uuid}/download
HeadersAuthorization, Content-Type
Path Parametersuuid
Query ParametersNA

Downloads the backup of a device. You can only download Config backups (We create Config backups of Equinix-Configured devices).

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

A sample curl request to download the backup of a device.

curl -X
PATCH "https://api.equinix.com/ne/v1/deviceBackups/d186dc1a-29e7-4829-bb5e-50fa57aca923/download"
-H "content-type: application/json"
-H "Authorization: Bearer jnSoUKaJHpzMnU0toROpUHmqnwEP"

Path parameter:

Path Parameter NameMandatoryTypeExampleApplicable ValuesDescription
uuidYesstring6953b3d7-713d-4412-b6d7-0c5fc5e2a800The unique Id of a backup.

Sample response.

Building configuration...
Current configuration : 9531 bytes
!
! Last configuration change at 18:17:14 UTC Wed Apr 21 2021 by SDNSS
! NVRAM config last updated at 18:17:15 UTC Wed Apr 21 2021 by SDNSS
!
version 16.9
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
! Call-home is enabled by Smart-Licensing.
service call-home
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
platform console virtual
platform hardware throughput level MB 500
!
hostname test
!
boot-start-marker
boot-end-marker
!
!
vrf definition MGMT
!
address-family ipv4
exit-address-family
!
vrf definition cloud
rd 12345:16045
!
address-family ipv4
route-target export 12345:16045
route-target import 12345:16045
exit-address-family
!
address-family ipv6
route-target export 12345:16045
route-target import 12345:16045
exit-address-family
!
vrf definition external
!
address-family ipv4
exit-address-family
!
logging buffered 100000
enable secret 9 $9$2qBb/RHdr10s9h$pFDvScFJLXWWtrCZ0nPohm4DJ8PqsE8W.fR482ecBU2
!
aaa new-model
!
!
aaa group server tacacs+ tacacs-servers
server-private 10.198.250.193 port 8000 key 7 0223154E5A085E39181D5B4844
ip vrf forwarding MGMT
ip tacacs source-interface GigabitEthernet1
!
aaa authentication login vnf local group tacacs-servers
aaa authentication enable default group tacacs-servers enable
aaa authorization console
aaa authorization config-commands
aaa authorization exec vnf local group tacacs-servers
aaa authorization commands 1 default local group tacacs-servers
aaa authorization commands 15 default local group tacacs-servers
aaa authorization commands visible-keys
aaa accounting commands 1 default start-stop group tacacs-servers
aaa accounting commands 15 default start-stop group tacacs-servers
!
!
!
!
!
aaa session-id common
call-home
! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
contact-email-addr sch-smart-licensing@cisco.com
profile "CiscoTAC-1"
active
destination transport-method http
no destination transport-method email
no ip source-route
no ip gratuitous-arps
!
!
!
!
!
!
!
no ip bootp server
ip name-server vrf MGMT 10.255.255.6
no ip domain lookup
ip domain name nfvportal.equinix.com
!
!
!
login on-failure log
login on-success log
!
!
!
!
!
!
!
subscriber templating
!
!
!
!
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
crypto pki trustpoint SLA-TrustPoint
enrollment terminal
revocation-check crl
!
!
crypto pki certificate chain SLA-TrustPoint
certificate ca 01
30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030
32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363
6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934
3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305
43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720
526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030
82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D
CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520
1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE
4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC
7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188
68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7
C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191
C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44
DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201
06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85
4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500
03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905
604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B
D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8
467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C
7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B
5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678
80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB
418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0
D697DF7F 28
quit
!
license udi pid C8000V sn 9O7VOJN6OU7
license accept end user agreement
license boot level security
license smart enable
license smart utility customer_info id "91258"
license smart utility customer_info name "nfvsit02 nfvsit02"
license smart utility
license smart url http://10.195.244.50:80/Transportgateway/services/DeviceRequestHandler
license smart transport smart
diagnostic bootup level minimal
!
!
!
username SDNSS privilege 15 secret 9 $9$2qBb/RHdr10s9h$pFDvScFJLXWWtrCZ0nPohm4DJ8PqsE8W.fR482ecBU2
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
vrf forwarding external
ip address 192.168.1.1 255.255.255.255
no ip redirects
no ip unreachables
no ip proxy-arp
no ipv6 redirects
no ipv6 unreachables
no keepalive
!
interface GigabitEthernet1
description MGMT interface
vrf forwarding MGMT
ip address 10.198.251.47 255.255.255.0
negotiation auto
!
interface GigabitEthernet2
description SSH Interface
vrf forwarding external
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
negotiation auto
ipv6 nd ra suppress all
no ipv6 redirects
no ipv6 unreachables
no keepalive
no lldp transmit
no lldp receive
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4
description TEST-SROY-LINK
mtu 8950
vrf forwarding cloud
ip address 192.164.0.2 255.255.255.224
speed 10000
no negotiation auto
ipv6 enable
!
interface GigabitEthernet5
description L3-ORACLE-SIT_SV
mtu 8950
vrf forwarding cloud
ip address 64.191.223.87 255.255.255.254
speed 10000
no negotiation auto
ipv6 enable
!
interface GigabitEthernet6
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet7
description AWS Direct Connect
mtu 8950
vrf forwarding cloud
ip address 10.0.1.1 255.255.255.252
speed 10000
no negotiation auto
ipv6 enable
!
interface GigabitEthernet8
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet9
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet10
description AWS Direct Connect
mtu 8950
vrf forwarding cloud
ip address 11.0.1.1 255.255.255.252
speed 10000
no negotiation auto
ipv6 enable
!
router bgp 12345
bgp router-id 192.168.1.1
bgp log-neighbor-changes
!
address-family ipv4 vrf cloud
neighbor 10.0.1.2 remote-as 21345
neighbor 10.0.1.2 password 7 11081B06464058
neighbor 10.0.1.2 activate
neighbor 10.0.1.2 remove-private-as
neighbor 10.0.1.2 route-map REJECT-BOGON in
neighbor 10.0.1.2 maximum-prefix 2000
neighbor 11.0.1.2 remote-as 21345
neighbor 11.0.1.2 activate
neighbor 11.0.1.2 remove-private-as
neighbor 11.0.1.2 route-map REJECT-BOGON in
neighbor 11.0.1.2 maximum-prefix 2000
neighbor 64.191.223.86 remote-as 25658
neighbor 64.191.223.86 activate
neighbor 64.191.223.86 remove-private-as
neighbor 64.191.223.86 route-map REJECT-BOGON in
neighbor 64.191.223.86 maximum-prefix 2000
maximum-paths eibgp 8
exit-address-family
!
address-family ipv6 vrf cloud
maximum-paths eibgp 8
exit-address-family
!
!
virtual-service csr_mgmt
ip shared host-interface GigabitEthernet1
!
no ip forward-protocol nd
no ip forward-protocol udp
no ip forward-protocol udp tftp
no ip forward-protocol udp nameserver
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
no ip http server
no ip http secure-server
ip http client source-interface GigabitEthernet1
ip route vrf MGMT 0.0.0.0 0.0.0.0 10.198.251.1
!
ip ssh time-out 60
ip ssh logging events
ip ssh version 2
ip ssh dh min size 4096
ip ssh server algorithm mac hmac-sha1
ip ssh server algorithm encryption aes256-ctr
!
!
ip prefix-list ipv4-martians seq 10 permit 0.0.0.0/8 le 32
ip prefix-list ipv4-martians seq 20 permit 127.0.0.0/8 le 32
ip prefix-list ipv4-martians seq 30 permit 169.254.0.0/16 le 32
ip prefix-list ipv4-martians seq 40 permit 224.0.0.0/4 le 32
ip prefix-list ipv4-martians seq 50 permit 240.0.0.0/4 le 32
ip prefix-list ipv4-martians seq 60 permit 255.255.255.255/32
!
!
route-map REJECT-BOGON deny 10
match ip address prefix-list ipv4-martians
!
route-map REJECT-BOGON permit 20
!
snmp-server location SVSV5
!
!
!
!
control-plane
!
banner login ^CC
==========================================================

Access to this system is limited to authorized users for
company business purposes only.

WARNING: All unauthorized access is prohibited.

==========================================================
^C
!
line con 0
exec-timeout 30 0
privilege level 15
login authentication vnf
stopbits 1
line vty 0 4
exec-timeout 30 0
login authentication vnf
transport input ssh
transport output ssh
!
ntp source GigabitEthernet1
ntp server vrf MGMT 172.22.64.177 prefer
ntp server vrf MGMT 172.22.244.245
!
!
!
!
!
end

The description of the response payload:

HTTP StatusDescription
200: OkayThe backup is in the format of a string.

Get Backup of Device {uuid}

 GET /ne/v1/deviceBackups/{uuid}
MethodGET
URL or End Point/ne/v1/deviceBackups/{uuid}
HeadersAuthorization, Content-Type
Path Parametersuuid
BodyNot applicable

Returns the backups of a virtual device by the unique ID of a backup.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

A sample curl request.

curl -X
GET "https://api.equinix.com/v1/deviceBackups/4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
-H "content-type: application/json"
-H "authorization: Bearer qwErtY8zyW1abcdefGHI"

The description of the query parameters is as follows:

Path ParameterMandatoryTypeExampleApplicable ValuesDescription
uuidYesstring7ef81cbe-01ed-4c27-8b2f-69d3a3fd4d6aUnique Id of a backup.

Sample response:

        {
"uuid": "0474d78d-cefd-4546-8126-fb0d65c50a79",
"name": "config1",
"version": "16.09.02",
"type": "CONFIG",
"status": "DELETED",
"createdBy": "eqxnfvuser999",
"lastUpdatedDate": "2021-04-02 20:08:28.072",
"downloadUrl": "/nfv/v1/deviceBackups/0474d78d-cefd-4546-8126-fb0d65c50a79/download",
"deleteAllowed": false,
"restores": [
{
"uuid": "7hgj5675-5c3f-4275-adba-0c9e3c26c45y",
"status": "COMPLETED",
"createdBy": "cust0001",
"createdDate": "2018-01-30T10:30:31.387Z",
"lastUpdatedDate": "2018-01-30T10:30:31.387Z"
}
],
"deviceUuid": "4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
}

The description of the response payload is as follows:

FieldTypeExample ValuesDescription
uuidstring6ea5a0e4-2bf7-45c2-9aa7-e846a8cd5567Unique Id of the backup.
namestringmy-sroy-BackupName of the backup.
versionstring16.09.02Version of the device.
typestringCONFIGType of the backup.
statusstringCOMPLETEDStatus of the backup.
createdBystringnfv-sit1Created by username.
lastUpdatedDatestring2018-08-30T04:20:36.033ZLast update date.
downloadUrlstring"/nfv/v1/deviceBackups/02cd28c5-3e4b-44ff-ad86-bb01eb3e5863/download"The URL where the backup is downloadable.
deleteAllowedstringtrueWhether the backup can be deleted. Only backups in "COMPLETED" or "FAILED" states can be deleted.
restoresarrayAn array of objects.
restores.uuidstring6ea5a0e4-2bf7-45c2-9aa7-e846a8cd5567Unique Id of the backup.
restores.statusstringCOMPLETEDStatus of the backup.
restores.createdBystringnfv-sit1Created by username.
restores.createdDatestring2018-08-30T04:20:36.033ZLast update date.
restores.lastUpdatedDatestring2018-08-30T04:20:36.033ZLast update date.
deviceUuidstring9jgj5675-5c3f-4275-adba-0c9e3c26c67gUnique Id of the device.
 

If you get “Access Denied” error, contact your local Equinix Service Desk.

Get Backups of Device

 GET /ne/v1/deviceBackups
MethodGET
URL or End Point/ne/v1/deviceBackups
HeadersAuthorization, Content-Type
Query ParametersvirtualDeviceUuid, status [], offset, limit
BodyNot applicable

Returns the backups of a virtual device.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

A sample curl request.

curl -X
GET "https://api.equinix.com/v1/deviceBackups?virtualDeviceUuid=4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
-H "content-type: application/json"
-H "authorization: Bearer qwErtY8zyW1abcdefGHI"

The description of the query parameters is as follows:

Query ParameterMandatoryTypeExampleApplicable ValuesDescription
virtualDeviceUuidYesstring7ef81cbe-01ed-4c27-8b2f-69d3a3fd4d6aUnique Id of a virtual device.
statusNoarrayAn array of status values.
offsetNointeger0Specifies where to start a page. It is the starting point of the collection returned from the server.
limitNointeger100Specifies the page size.

Sample response:

{
"pagination": {
"offset": 0,
"limit": 20,
"total": 3
},
"data": [
{
"uuid": "0474d78d-cefd-4546-8126-fb0d65c50a79",
"name": "config1",
"version": "16.09.02",
"type": "CONFIG",
"status": "DELETED",
"createdBy": "eqxnfvuser999",
"lastUpdatedDate": "2021-04-02 20:08:28.072",
"downloadUrl": "/nfv/v1/deviceBackups/0474d78d-cefd-4546-8126-fb0d65c50a79/download",
"deleteAllowed": false,
"deviceUuid": "4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
},
{
"uuid": "02cd28c5-3e4b-44ff-ad86-bb01eb3e5863",
"name": "with_out_services",
"version": "16.09.02",
"type": "CONFIG",
"status": "COMPLETED",
"createdBy": "eqxnfvuser999",
"lastUpdatedDate": "2021-04-03 00:26:53.662",
"downloadUrl": "/nfv/v1/deviceBackups/02cd28c5-3e4b-44ff-ad86-bb01eb3e5863/download",
"deleteAllowed": true,
"deviceUuid": "4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
},
{
"uuid": "f4436774-fa06-4551-bc8d-aa74a5101a85",
"name": "123",
"version": "16.09.02",
"type": "CONFIG",
"status": "COMPLETED",
"createdBy": "eqxnfvuser999",
"lastUpdatedDate": "2021-04-02 17:17:21.419",
"downloadUrl": "/nfv/v1/deviceBackups/f4436774-fa06-4551-bc8d-aa74a5101a85/download",
"deleteAllowed": true,
"restores": [
{
"uuid": "7hgj5675-5c3f-4275-adba-0c9e3c26c45y",
"status": "COMPLETED",
"createdBy": "cust0001",
"createdDate": "2018-01-30T10:30:31.387Z",
"lastUpdatedDate": "2018-01-30T10:30:31.387Z"
}
],
"deviceUuid": "4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
}
]
}

The description of the response payload is as follows:

FieldTypeExample ValuesDescription
paginationobjectAn object that has pagination information.
offsetinteger0It is the starting point of the collection returned from the server.
limitinteger20The page size.
totalinteger100The total number of results.
nextstringThe next set of records.
previousstringThe previous set of records.
dataarrayAn array of link objects.
uuidstring6ea5a0e4-2bf7-45c2-9aa7-e846a8cd5567Unique Id of the backup.
namestringmy-sroy-BackupName of the backup.
versionstring16.09.02Version of the device.
typestringCONFIGType of the backup.
statusstringCOMPLETEDStatus of the backup.
createdBystringnfv-sit1Created by username.
lastUpdatedDatestring2018-08-30T04:20:36.033ZLast update date.
downloadUrlstring"/nfv/v1/deviceBackups/02cd28c5-3e4b-44ff-ad86-bb01eb3e5863/download"The URL where the backup is downloadable.
deleteAllowedstringtrueWhether the backup can be deleted. Only backups in "COMPLETED" or "FAILED" states can be deleted.
restoresarrayAn array of objects.
restores.uuidstring6ea5a0e4-2bf7-45c2-9aa7-e846a8cd5567Unique Id of the backup.
restores.statusstringCOMPLETEDStatus of the backup.
restores.createdBystringnfv-sit1Created by username.
restores.createdDatestring2018-08-30T04:20:36.033ZLast update date.
restores.lastUpdatedDatestring2018-08-30T04:20:36.033ZLast update date.
deviceUuidstring9jgj5675-5c3f-4275-adba-0c9e3c26c67gUnique Id of the device.
 

If you get “Access Denied” error, contact your local Equinix Service Desk.

Restore a Backup

 PATCH /ne/v1/devices/{uuid}/restore
MethodPATCH
URL or End Point/ne/v1/devices/{uuid}/restore
HeadersAuthorization, Content-Type
Path Parametersuuid
Query ParametersbackupUuid

Restores any backup of a device. To check whether you can restore a backup, call Check Feasibility of Restore.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

A sample curl request to restore any backup of a device.

curl -X
PATCH "https://api.equinix.com/ne/v1/devices/d186dc1a-29e7-4829-bb5e-50fa57aca923/restore?backupUuid=4cfb5675-5c3f-4275-adba-0c9e3c26c96b"
-H "content-type: application/json"
-H "Authorization: Bearer jnSoUKaJHpzMnU0toROpUHmqnwEP"

Path parameter:

Path Parameter NameMandatoryTypeExamplePossible ValuesDescription
uuidYesstring6953b3d7-713d-4412-b6d7-0c5fc5e2a800The unique ID a device.

The description of the query parameters is as follows:

Query Parameter NameMandatoryTypeExamplePossible ValuesDescription
backupUuidYesstring4cfb5675-5c3f-4275-adba-0c9e3c26c96bThe unique ID of a backup.

Sample response.

204: No Content

Response payload:

HTTP StatusDescription
204: No ContentThe request was successfully processed.

Update Device Backup

 PATCH /ne/v1/deviceBackups/{uuid}
MethodPATCH
URL or End Point/ne/v1/deviceBackups/{uuid}
HeadersAuthorization, Content-Type
Path Parametersuuid
Body Parametersname

Updates the name of a backup.

 

To obtain an authorization token, refer to Requesting Access and Refresh tokens under the Getting Access Token section.

A sample curl request to update a backup name.

curl -X
PATCH "https://api.equinix.com/ne/v1/deviceBackups/d186dc1a-29e7-4829-bb5e-50fa57aca923"
-H "content-type: application/json"
-H "Authorization: Bearer jnSoUKaJHpzMnU0toROpUHmqnwEP"
-d '{
"name": "my Second Name"
}'

Path parameter:

Path Parameter NameMandatoryTypeExampleApplicable ValuesDescription
uuidYesstring6953b3d7-713d-4412-b6d7-0c5fc5e2a800The unique Id a device backup.

The description of the body parameters is as follows:

Body Parameter NameMandatoryTypeExamplePossible ValuesDescription
nameYesstringMy new nameThe name of the backup.

Sample response.

204: No Content

The description of the response payload:

HTTP StatusDescription
204: No ContentThe request was successfully processed.